Revolut Withdrawals Degraded Performance

Incident Report for Coinbase

Resolved

This incident has been resolved.
Posted Mar 17, 2025 - 16:55 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 17, 2025 - 16:04 PDT

Investigating

We are aware that some UK customers are experiencing failures for withdrawals to Revolut bank accounts. Our team is investigating this issue and will provide an update shortly. In the meantime, you may try other withdrawal options.
Posted Mar 17, 2025 - 14:48 PDT