IMPS payments are currently disabled

Incident Report for Coinbase

Resolved

We are currently unable to support IMPS as a payment method. We will continue to explore other options.
Posted Mar 14, 2023 - 08:55 PDT

Investigating

We are currently investigating an issue with IMPS payments.
Posted Jan 14, 2023 - 00:26 PST