EOS delayed withdrawal requests
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted Feb 14, 2020 - 13:03 PST
Monitoring
We are actively monitoring this issue
Posted Feb 14, 2020 - 09:06 PST
This incident affected: Digital Currencies (EOS).