Stacks (STX) - Delayed Sends & Receives

Incident Report for Coinbase

Resolved

This incident has been resolved.
Posted Feb 10, 2025 - 12:18 PST

Investigating

We are aware that some users may be experiencing delayed sends and receives for Stacks (STX). Buys, Sells, and Fiat withdrawals/deposits are not affected. We are investigating this issue and will provide an update shortly. Rest assured, your funds are safe.
Posted Feb 10, 2025 - 07:25 PST