Futures market are delayed to re-open
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted Sep 26, 2024 - 18:47 PDT
Investigating
Futures markets are currently closed due to an active incident with the DCM exchange that is delaying open.
Posted Sep 26, 2024 - 15:07 PDT