We are experiencing intermittent issues with processing PayPal withdrawals in EUR.
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted 6 months ago. Apr 21, 2019 - 13:55 PDT
Investigating
We are currently investigating this issue.
Posted 6 months ago. Apr 21, 2019 - 10:01 PDT
This incident affected: Payment Methods (PayPal).