Delays in US Wires
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted Mar 24, 2020 - 08:48 PDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 23, 2020 - 15:17 PDT
Identified
USD Wires from one of our service providers may be delayed
Posted Mar 20, 2020 - 11:50 PDT
This incident affected: Payment Methods (US Wires).